Back to overview
Degraded

SYD-03 Degraded Performance

Nov 14 at 06:19pm NZDT

Resolved
Nov 14 at 06:24pm NZDT

Issue appears to have resolved itself? Only approximately 15 minutes of degraded service.

Created
Nov 14 at 06:19pm NZDT

SYD-03 is having connectivity issues. Struggling to maintain connection to Steam servers and external databases.