Back to overview
Downtime

Game Server Control Panel Down

Nov 17 at 04:41pm NZDT

Resolved
Nov 17 at 04:54pm NZDT

The vendor has resolved this issue and the panel appears to be responsive.

Created
Nov 17 at 04:41pm NZDT

The game server control panel is unresponsive, resulting in downtime. The vendor has been notified and recovery is underway.