Back to overview
Downtime
PMR DC Offline
Jun 6, 2026 at 10:17am UTC
Affected services
Web Hosting Network NZ
Resolved
Jun 6, 2026 at 10:27am UTC
Nodes are now recovering. Please report any abnormalities to our technical team.
Affected services
Updated
Jun 6, 2026 at 10:22am UTC
Our team have identified the issue and are working to resolve this presently.
Affected services
Created
Jun 6, 2026 at 10:17am UTC
Palmerston North Datacenter is offline - our team is investigating this with urgency
Affected services